phpbb3 et spip2

SPIP, Collaborative Portal Server, serveurs d'application (Zope),...

Modérateur: Equipe de modération des forums

Re: phpbb3 et spip2

Message par alxgomz » 18 Oct 2009, 11:00

J a écrit :
Euh c voulu les articles externes se retrouvent en page d'acceuil (leur place aurait pplutôt été dans la rubrique "nouveautés sur le web)?
J'ose espérer que c'est un bug...


un article externe ? tu veux parler d'un article virtuel ?

en fait tous les articles se retrouve en page centrale tries par date, les plus recents en haut, qqsoit leur rubrique de postage ! c'est le squelette par defaut qui veut ca... si tu ne veux pas que tes articles se retrouvent en page avant, seule solution sans reprogrammer le squelette et tout chambouler c'est de mentir sur la date !! tu lui mets une date ancestrale genre 1998 et hop il se retrouve en queue de peloton...

Non tu n'a pas compris ce que je voulais dire... vois avec pahure pour avoir plus d'infos il a traité le problème (en supprimant des auteurs je crois)
Happy debian user
Avatar de l’utilisateur
alxgomz
Equipe LoLiTa
 
Message(s) : 459
Inscription : 21 Juin 2007, 23:18
Localisation : Faa'a

Re: Pénible ce nouveau forum!

Message par alxgomz » 18 Oct 2009, 11:28

J a écrit :pour garder les cookies, le parametre ffx doit etre sur : conserver les cookies jusqu'a leur expiration, et bien sur ne pas les effacer quand tu fermes le ffx...


1 - Je n'utilise pas FF
2 - Crois tu m'apprendre le fonctionnement des cookies?... je ne suis pas le seul à souffrir de ce problème... Il y a un réel problème avec l'authentification (entre autres), il faut juste l'admettre!
Happy debian user
Avatar de l’utilisateur
alxgomz
Equipe LoLiTa
 
Message(s) : 459
Inscription : 21 Juin 2007, 23:18
Localisation : Faa'a

Re: phpbb3 et spip2

Message par J » 18 Oct 2009, 18:32

comment veux-tu que je l'admette ? pour cela je dois pouvoir reproduire ce que vous constatez...

donc quand vous dites cela ne marche pas etc, vous serez sympas d'indiquer le contexte comme dans un vrai depannage... si tu avais dit des le depart quel navigateur tu utilisais ?

pour la confidentialite des messages, j'ai suggere plus haut, qu'on se retrouve dans cette section du forum lundi 12h pour poster, on verra alors si on voit nos messages...

pour tes articles externes si tu dis que arnaud avait regle le probleme, il aurait ete plus judicieux pour toi de lui envoyer une note a ce propos... et pas juste venir raler, de plus pour l'argumentation, si tu voulais vraiment raler et te faire comprendre .... un lien spip sur un article externe ??

d'ailleurs tu peux toujours le poster ici...
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana

Re: phpbb3 et spip2

Message par alxgomz » 18 Oct 2009, 19:44

J a écrit :comment veux-tu que je l'admette ? pour cela je dois pouvoir reproduire ce que vous constatez...

OK donc principe J n°1: J'ai raison, charge aux autres de me prouver que j'ai tort (quand bien même les autres sont des gens compétents et au fait de la "chose informatique")

J a écrit :donc quand vous dites cela ne marche pas etc, vous serez sympas d'indiquer le contexte comme dans un vrai depannage... si tu avais dit des le depart quel navigateur tu utilisais ?


principe J n°2: Si j'ai tort renvoyer la faute sur les autres.

J a écrit :pour la confidentialite des messages, j'ai suggere plus haut, qu'on se retrouve dans cette section du forum lundi 12h pour poster, on verra alors si on voit nos messages...


principe J n°3: Quand il apparait évident que j'ai tort mettre en doute le preuves... (un screenshot de dominix le tricheur! et un screencast de alxgomz l'enquiquineur)

J a écrit :pour tes articles externes si tu dis que arnaud avait regle le probleme, il aurait ete plus judicieux pour toi de lui envoyer une note a ce propos... et pas juste venir raler, de plus pour l'argumentation, si tu voulais vraiment raler et te faire comprendre .... un lien spip sur un article externe ??
d'ailleurs tu peux toujours le poster ici...


Arnaud a réglé le problème après que j'ai posté un message sur le forum signalant le problème. Si tu relis le post tu verras qu'il était très poli qu'il ne contient aucune trace de ralerie ou d'agressivité. Je ne rale que lorsque les choses l'exigent, et je sais souligner quand les choses vont dans le bon sens.... parfois un peu trop vite: http://www.lolita.pf/forums/viewtopic.php?f=27&t=1168#p6925
Happy debian user
Avatar de l’utilisateur
alxgomz
Equipe LoLiTa
 
Message(s) : 459
Inscription : 21 Juin 2007, 23:18
Localisation : Faa'a

Re: phpbb3 et spip2

Message par RFRF » 18 Oct 2009, 19:45

sous ff cokies activé:
je me connecte et m'enregistre.

edition du cookie :
Name bbas_pass_code
Value xxxxxxxxxxxxxxxxxxxxx
Domaine (host) http://www.linux.pf
Chemin d'accès (path) /
Sécurisé non
Expire le Sun, 15 Aug 2010 05:31:00 GMT

L'option cookies de session n'est pas cochée.
Il était 19h31 donc léger décalage horaire.

Je ferme ff réouvre vais sur linux.pf
Et là plus de cookies.
je me réenregistre et un nouveau cookie est crée.

Autrement dit le cookie s'efface de lui même.

Si ca peut aider.
RFRF
Noobs
 
Message(s) : 65
Inscription : 14 Jan 2009, 15:25

Re: phpbb3 et spip2

Message par jdg » 18 Oct 2009, 19:50

Pour info:
    J'ai le même problème de connexion sous Firefox.
    Je constate aussi que le titre "LoLiTa: ..." est décalé.
jdg
Noobs
 
Message(s) : 115
Inscription : 25 Fév 2005, 15:23

Re: phpbb3 et spip2

Message par J » 18 Oct 2009, 20:19

Pour info:
J'ai le même problème de connexion sous Firefox.
Je constate aussi que le titre "LoLiTa: ..." est décalé.


ahaa, je comprends enfin ce que dom a voulu dire ! et vous avez raison pour lolita qui depasse, toutes mes excuses (je croyais qu'il parlait du depassement des images en pieces jointes dans le forum) !

mais c'est juste un probleme de css... et je vous promet pas de le regler dans l'heure, je suis un peu bigleux pour la visee...

pour le navigateur alex, meme si tu as raison sur mon impolitesse, mon insultance irrespect envers de tels professionnels que vous etes ..., je te serai eminemment reconnaissant de me dire quel navigateur tu utilises ?

mon but principal est de regler les bugs ... et rien d'autre, je suis desole si parfois je suis sec.
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana

Re: phpbb3 et spip2

Message par J » 18 Oct 2009, 20:23

pour les cookies sous ffx3 je n'ai pas ce probleme:

j'ai fait le test hier :

prefs ffx3/vie privee/accepter les cookies/les conserver jusqu'a leur expiration

apres sans me delogguer, j'ai quitte toutes les fenetres ffx3, j'ai attendu qqs secondes, j'ai reouvert une autre fenetre , j'ai clique le site lolita.pf puis forums comme dans une vrai navigation... et je suis arrive sur le forum avec le statut connecte, sans meme avoir precedemment active l'option "rester connecte" lors du precedent login.

merci rfrf de m'aider !

a propos du cookie, celui que tu as lu n'est pas le bon !
le cookie du forum s'appelle phpbb3_fkf46_k
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana

Re: phpbb3 et spip2

Message par J » 18 Oct 2009, 20:33

pour la visee css, vous desirez :

que le titre LoLiTa : Logiciels Libres à Tahiti et dans les îles soit au dessus dans le bandeau bleutee en compagnie de tux et de linux ?
ou que le titre soit en dessous du bandeau et ne touche plus la bordure noire du cadre du bandeau ?
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana

Re: phpbb3 et spip2

Message par J » 18 Oct 2009, 23:50

j'ai descendu le titre dans la css de personnalisation sous la bordure noire dans la zone blanche pour eviter de toucher au bandeau image.

notes: cette css de personnalisation, je l'avais recuperee sur l'ancien site en spip 1.9.2c ! et elle n'avait pas cet effet de bord... peut-etre l'action alternative est differente de ahuntsic ?
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana

Re: phpbb3 et spip2

Message par RFRF » 19 Oct 2009, 06:38

En passant par lolita.pf/forum avec mes sabots, j'ai bien le cookie dont tu parles.
MAIS par linux.pf/forum j'ai celui dont je t'ai parlé, n'en déplaise aux trois capitaines.

Le problème est là je pense. Vous avez crée 2 phpbb3 paratageant la même SQL mais pas avec le même paramétrage?

Fallait juste dire que c'est lolita.pf/forum la bonne adresse


EDIT : je confirme, test effectué sous lolita.pf/forum, no problemo de connexion
RFRF
Noobs
 
Message(s) : 65
Inscription : 14 Jan 2009, 15:25

Re: phpbb3 et spip2

Message par oviri » 19 Oct 2009, 08:56

+1
j'allais également sur linux.pf/forums -> problèmes d'authentification
sur lolita.pf/forums -> auth ok
"Tamarii Na Te Oviri"
Avatar de l’utilisateur
oviri
Noobs
 
Message(s) : 357
Inscription : 20 Juin 2004, 01:17
Localisation : IRIPAU - UPORU

Re: phpbb3 et spip2

Message par alxgomz » 19 Oct 2009, 08:59

Comportement confirmé ici. Merci RFRF bien vu!
Apparement ça ne viens pas des versions de navigateurs?... quel surprise quand même!
Happy debian user
Avatar de l’utilisateur
alxgomz
Equipe LoLiTa
 
Message(s) : 459
Inscription : 21 Juin 2007, 23:18
Localisation : Faa'a

Re: phpbb3 et spip2

Message par J » 19 Oct 2009, 11:28

ben ouais, j'aurai pu le dire aussi, parce que ca figure noir sur blanc dans les params de phpbb3 ! le cookie est config sur lolita.pf , et un param de securite interne empeche l'initialisation cookie provenant d'un autre chemin.

mais quand on a le nez pres du tableau, on ne voit pas forcement la solution qui creve les yeux en s'en eloignant... donc merci rfrf (surtout que moi qui ai fait tous les tests a partir de lolita.pf, j'ignorais totalement que vous le faisiez avec linux.pf).

quant a l'install phpbb3, ce n'est pas 2 pour 1 db sql, mais 2 nom de domaines sur un meme espace physique qui est d'ailleurs fortement limite !
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana

Re: phpbb3 et spip2

Message par J » 19 Oct 2009, 12:09

j' ai mis un peu de temps avant de comprendre le probleme de confidentialite des messages (quand c'est arrive), ton ogg est flou et ca va assez vite, j'ai du relire le sujet de rfrf sur postfix pour comprendre (ce qui a du arriver);

je pense donc (d'apres tous les params de secu supplementaire de phpbb3 et ce que j'ai pu voir du code) que les developpeurs ont du lier l'horodation des messages avec la verification cookie; etant donne que vous etiez tous sur linux.pf au lieu de lolita.pf, le programme a du melanger ses pinceaux...

dorenavant, j'essaierai d'etre moins sec, n'hesitez pas a me le faire savoir quand je depasse les bornes, alex tes remontrances sont excellentes...
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana

PrécédentSuivant

Retour vers CMS - Systèmes de Gestion de Contenu

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron