[Résolu] Problème de MAJ ubuntu 7.04 (feisty)

Debian, Mandrake, Gentoo, LFS, Fedora, Knoppix, Slackware,... il y a forcément une distribution qui vous colle à la peau :)

Modérateur: Equipe de modération des forums

[Résolu] Problème de MAJ ubuntu 7.04 (feisty)

Message par Cocobu » 14 Août 2007, 16:36

Salut, j'ai enfin tester cette fameuse UBUNTU, tout s'installe bien sauf qqs problème de résolutions mais passons.

Au moment de mettre à jour :
Code : Tout sélectionner
sudo apt-get update


j'ai une erreur :
Code : Tout sélectionner
W: GPG error: http://security.ubuntu.com feisty-security Release: Les signatures suivantes ne sont pas valables : BADSIG 40976EAF437D05B5 Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>


Et grace à mon amis google, je vous aporte la solution.
En fait c'est un problème dù aux cache transparents (comme c'est le cas chez MANA ...)
La solution est de bypasser les caches :
Code : Tout sélectionner
sudo apt-get update -o Acquire::http::No-Cache=True
Avatar de l’utilisateur
Cocobu
Equipe LoLiTa
 
Message(s) : 831
Inscription : 24 Mars 2004, 16:20
Localisation : Polynésie Française

Message par oviri » 15 Août 2007, 09:44

juste pour dire qu'il est préférable d'utiliser aptitude à la place d'apt-get (d'après ce qui ce disais sur les chan IRC debian(fr), aptitude gérerais mieux les dépendances, surtout lors de la suppressions des paquets)
Avatar de l’utilisateur
oviri
Noobs
 
Message(s) : 357
Inscription : 20 Juin 2004, 01:17
Localisation : IRIPAU - UPORU

Message par Cocobu » 16 Août 2007, 08:33

Je viens de tester aptitude et j'ai la même erreur donc je continue à utiliser apt-get.
Avatar de l’utilisateur
Cocobu
Equipe LoLiTa
 
Message(s) : 831
Inscription : 24 Mars 2004, 16:20
Localisation : Polynésie Française

Message par oviri » 19 Août 2007, 16:07

je ne conseillais pas aptitude pour résoudre l'erreur plus haut. Si c'est ton choix d'utiliser apt-get, aita e peapea :)
Avatar de l’utilisateur
oviri
Noobs
 
Message(s) : 357
Inscription : 20 Juin 2004, 01:17
Localisation : IRIPAU - UPORU

Message par J » 21 Août 2007, 10:53

cette erreur est commune a toutes les versions ubuntu que j'ai testees, installations faites a partir du live
le key du cd doit etre different de ceux disponibles sur les serveurs de maj
je ne connais pas la procedure pour mettre a jour les cles
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana

Message par Cocobu » 16 Jan 2008, 11:49

Pour mettre le paramètre précédant dans le fichier de conf d'apt-get, il suffit de créer un fichier /etc/apt/apt.conf.d/90no-cache avec le contenu suivant :
Code : Tout sélectionner
Acquire
{
        http
        {
                No-Cache "true";
        };
};

En espérant que ca en aidera plus d'un.
Avatar de l’utilisateur
Cocobu
Equipe LoLiTa
 
Message(s) : 831
Inscription : 24 Mars 2004, 16:20
Localisation : Polynésie Française

Merci

Message par cwgar » 19 Jan 2008, 09:45

C'est super ça fonctionne même pour Synaptic !
Fororino
Avatar de l’utilisateur
cwgar
Noobs
 
Message(s) : 12
Inscription : 22 Oct 2005, 23:51
Localisation : Pamatai Faa'a

Message par J » 21 Jan 2008, 12:19

ubuntu-fr.org donne un tuto pour les cles
Gerer les cles d'authentification
Avatar de l’utilisateur
J
Equipe LoLiTa
 
Message(s) : 939
Inscription : 10 Jan 2005, 13:31
Localisation : Dans le cyberpf de mana


Retour vers Distributions

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité