[OK]Feisty et aptitude -f install[/OK]

Debian, Mandrake, Gentoo, LFS, Fedora, Knoppix, Slackware,... il y a forcément une distribution qui vous colle à la peau :)

Modérateur: Equipe de modération des forums

[OK]Feisty et aptitude -f install[/OK]

Message par oviri » 29 Avr 2007, 16:42

Iaorana,
juste pour savoir si j'ai pareil que vous, en faisant un sudo aptitude -f install (ou apt-get -f install) j'ai des tas de paquets cassés (j'ai upgrader, via l'outil graphique, depuis edgy). Si quelqu'un pouvais faire ça sur une feisty non upgrader depuis edgy.

le résultat de la commande :
Code : Tout sélectionner
oviri@rorouiratahi:~$ sudo aptitude -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture de l'information d'état... Fait
Lecture de l'information d'état étendu     
Initialisation de l'état des paquets... Fait
Construction de la base de données des étiquettes... Fait
Les paquets suivants sont CASSÉS :
  audacity beryl-core beryl-plugins compiz compiz-gtk courier-authlib
  desktop-effects evolution f-spot foo2zjs gaim gedit gnome-common
  gnome-mag gnomebaker gs-esp gstreamer0.10-plugins-bad
  gstreamer0.10-plugins-bad-multiverse heliodor intltool libberylsettings0
  libberylsettings0-gconf libbtctl4 libgnome-speech3 libmono-system1.0-cil
  libndesk-dbus-glib1.0-cil libndesk-dbus1.0-cil libnet-dbus-perl
  libpango1.0-0 libportaudio2 librdf0 libsasl2-2 libsvn1 libxalan2-java
  libxerces2-java openoffice.org python python-examples python-gd
  python-imaging-sane python-minimal python-scientific python-uno
  restricted-manager rhythmbox subversion tomboy update-manager
Les NOUVEAUX paquets suivants vont être automatiquement installés :
  lilo mbr
Les NOUVEAUX paquets suivants vont être installés :
  libgd2-noxpm lilo mbr
Les paquets suivants seront ENLEVÉS :
  automake1.7 command-not-found command-not-found-data compiz-core
  compiz-plugins dhcdbd dpatch espeak espeak-data expect
  gstreamer0.10-ffmpeg imlib-base imlib11 imlib11-dev libapr1 libaprutil1
  libdb4.2 libespeak1 libgd2-xpm libgdiplus libgs-esp8 libjack0.100.0-0
  libjaxp1.3-java libmjpegtools0c2a libmono-corlib2.0-cil
  libmono-data-tds2.0-cil libmono-security2.0-cil libmono-sharpzip2.84-cil
  libmono-sqlite2.0-cil libmono-system-data2.0-cil
  libmono-system-web2.0-cil libmono-system2.0-cil libmono2.0-cil
  libnl1-pre6 libnm-glib0 libnm-util0 libopenobex1 libpq5 libquicktime0
  libsamplerate0 libsoundtouch1c2 libthai0 libtiff4-dev libtiffxx0c2
  libungif4-dev libxcomposite1 libxml-twig-perl mscompress network-manager
  network-manager-gnome openoffice.org-filter-mobiledev python-notify
  python-numarray python2.5 python2.5-examples python2.5-minimal
  scim-modules-table scim-tables-additional tk8.5{p} update-manager-core
0 paquets mis à jour, 3 nouvellement installés, 60 à enlever et 0 non mis à jour.Il est nécessaire de télécharger 575ko d'archives. Après dépaquetage, 87,2Mo seront libérés.
Les paquets suivants ont des dépendances non satisfaites :
  beryl-core: Dépend: libxcomposite1 (>= 1:0.3-1) mais il n'est pas installable
  f-spot: Dépend: libmono-corlib2.0-cil (>= 1.2.3) mais il n'est pas installable
          Dépend: libmono-sharpzip2.84-cil (>= 1.0) mais il n'est pas installable
          Dépend: libmono-sqlite2.0-cil (>= 1.0) mais il n'est pas installable
          Dépend: libmono-system-data2.0-cil (>= 1.0) mais il n'est pas installable
          Dépend: libmono-system-web2.0-cil (>= 1.0) mais il n'est pas installable
          Dépend: libmono-system2.0-cil (>= 1.2.3) mais il n'est pas installable
          Dépend: libmono2.0-cil (>= 1.2.3) mais il n'est pas installable
  tomboy: Dépend: libmono-corlib2.0-cil (>= 1.2.3) mais il n'est pas installable
          Dépend: libmono-system2.0-cil (>= 1.2.3) mais il n'est pas installable
          Dépend: libmono2.0-cil (>= 1.2.3) mais il n'est pas installable
  python-examples: Dépend: python2.5-examples (>= 2.5.1~rc1) mais il n'est pas installable
  update-manager: Dépend: python2.5 mais il n'est pas installable
                  Dépend: update-manager-core mais il n'est pas installable
  gs-esp: Dépend: libgs-esp8 mais il n'est pas installable
  python-imaging-sane: Dépend: python-numarray mais il n'est pas installable
  libportaudio2: Dépend: libjack0.100.0-0 (>= 0.101.1) mais il n'est pas installable
  librdf0: Dépend: libpq5 mais il n'est pas installable
  libbtctl4: Dépend: libopenobex1 mais il n'est pas installable
  evolution: Dépend: libnm-glib0 mais il n'est pas installable
  desktop-effects: Dépend: libxcomposite1 (>= 1:0.3-1) mais il n'est pas installable
  audacity: Dépend: libjack0.100.0-0 (>= 0.101.1) mais il n'est pas installable
            Dépend: libsamplerate0 mais il n'est pas installable
            Dépend: libsoundtouch1c2 (>= 1.3.0) mais il n'est pas installable
  gnome-mag: Dépend: libxcomposite1 (>= 1:0.3-1) mais il n'est pas installable
  rhythmbox: Dépend: python2.5 (>= 2.5) mais il n'est pas installable
  compiz-gtk: Dépend: compiz-core (= 1:0.3.6-1ubuntu13) mais il n'est pas installable
  gedit: Dépend: python2.5 (>= 2.5) mais il n'est pas installable
  python-scientific: Dépend: python2.5 mais il n'est pas installable
  gstreamer0.10-plugins-bad-multiverse: Dépend: libmjpegtools0c2a (>= 1:1.8.0) mais il n'est pas installable
  subversion: Dépend: libapr1 mais il n'est pas installable
  restricted-manager: Dépend: python-notify (>= 0.1.1-0ubuntu2) mais il n'est pas installable
  libndesk-dbus1.0-cil: Dépend: libmono-corlib2.0-cil (>= 1.2.3) mais il n'est pas installableDépend: libmono-system2.0-cil (>= 1.2.3) mais il n'est pas installable
                        Dépend: libmono2.0-cil (>= 1.2.3) mais il n'est pas installable
  gnomebaker: Dépend: gstreamer0.10-ffmpeg mais il n'est pas installable
  python-minimal: Dépend: python2.5-minimal (>= 2.5.1~rc1) mais il n'est pas installable
  libsvn1: Dépend: libapr1 mais il n'est pas installable
           Dépend: libaprutil1 mais il n'est pas installable
  intltool: Dépend: automake1.7 mais il n'est pas installable ou
                     automaken qui est un paquet virtuel
  libberylsettings0: Dépend: libxcomposite1 (>= 1:0.3-1) mais il n'est pas installable
  python-gd: Dépend: libgd2-xpm (>= 2.0.34~rc1) mais il n'est pas installable
  libnet-dbus-perl: Dépend: libxml-twig-perl mais il n'est pas installable
  libpango1.0-0: Dépend: libthai0 (>= 0.1.7) mais il n'est pas installable
  libmono-system1.0-cil: Dépend: libgdiplus (>= 1.1.18) mais il n'est pas installable
  gnome-common: Dépend: automake1.9 mais il n'est pas installable ou
                         automaken qui est un paquet virtuel
  python-uno: Dépend: python2.5 (>= 2.5) mais il n'est pas installable
  python: Dépend: python2.5 (>= 2.5.1~rc1) mais il n'est pas installable
  openoffice.org: Dépend: openoffice.org-filter-mobiledev mais il n'est pas installable
  gaim: Dépend: libnm-glib0 mais il n'est pas installable
  libxerces2-java: Dépend: libjaxp1.3-java mais il n'est pas installable
  gstreamer0.10-plugins-bad: Dépend: libjack0.100.0-0 (>= 0.102.20) mais il n'est pas installable
                             Dépend: libsoundtouch1c2 (>= 1.3.0) mais il n'est pas installable
  libxalan2-java: Dépend: libjaxp1.3-java mais il n'est pas installable
  beryl-plugins: Dépend: libxcomposite1 (>= 1:0.3-1) mais il n'est pas installable
  courier-authlib: Dépend: expect mais il n'est pas installable
  libgnome-speech3: Dépend: libespeak1 mais il n'est pas installable
  foo2zjs: Dépend: mscompress mais il n'est pas installable
  libsasl2-2: Dépend: libdb4.2 mais il n'est pas installable
  heliodor: Dépend: libxcomposite1 (>= 1:0.3-1) mais il n'est pas installable
  libndesk-dbus-glib1.0-cil: Dépend: libmono-corlib2.0-cil (>= 1.2.3) mais il n'est pas installable
  compiz: Dépend: compiz-core mais il n'est pas installable
          Dépend: compiz-plugins mais il n'est pas installable
  libberylsettings0-gconf: Dépend: libxcomposite1 (>= 1:0.3-1) mais il n'est pas installable
Resolving dependencies...
Les actions suivantes permettront de résoudre ces dépendances :
Supprimer les paquets suivants :
compiz
compiz-gnome
compiz-gtk
desktop-effects
f-spot
libndesk-dbus-glib1.0-cil
libndesk-dbus1.0-cil
tomboy
ubuntu-desktop

Conserver les paquets suivants dans leur version actuelle :
automake1.7 [1.7.9-9 (feisty, now)]
command-not-found [0.2.4 (feisty, now)]
command-not-found-data [0.2.4 (feisty, now)]
espeak [1.21-0ubuntu1 (feisty, now)]
espeak-data [1.21-0ubuntu1 (feisty, now)]
expect [5.43.0-8build1 (feisty, now)]
gstreamer0.10-ffmpeg [0.10.2-0ubuntu4 (feisty, now)]
libapr1 [1.2.7-8.1 (feisty, now)]
libaprutil1 [1.2.7+dfsg-2build1 (feisty, now)]
libdb4.2 [4.2.52+dfsg-1build1 (feisty, now)]
libespeak1 [1.21-0ubuntu1 (feisty, now)]
libgd2-noxpm [Non installé]
libgd2-xpm [2.0.34~rc1-2ubuntu1 (feisty, now)]
libgdiplus [1.2.3-0ubuntu1 (feisty, now)]
libgs-esp8 [8.15.4.dfsg.1-0ubuntu1 (feisty, now)]
libjack0.100.0-0 [0.102.20-1 (feisty, now)]
libjaxp1.3-java [1.3.03-5 (feisty, now)]
libmjpegtools0c2a [1:1.8.0-0.2ubuntu3 (feisty, now)]
libnm-glib0 [0.6.4-6ubuntu7 (feisty, now)]
libopenobex1 [1.3-3 (feisty, now)]
libpq5 [8.2.4-0ubuntu0.7.04 (feisty-security, now)]
libquicktime0 [2:0.9.7-1ubuntu2 (feisty, now)]
libsamplerate0 [0.1.2-2 (feisty, now)]
libsoundtouch1c2 [1.3.0-2.1 (feisty, now)]
libthai0 [0.1.8-2 (feisty, now)]
libxcomposite1 [1:0.3.1-1 (feisty, now)]
libxml-twig-perl [1:3.26-2 (feisty, now)]
mscompress [0.3-2ubuntu1 (feisty, now)]
openoffice.org-filter-mobiledev [2.2.0-1ubuntu3 (feisty, now)]
python-notify [0.1.1-0ubuntu2 (feisty, now)]
python-numarray [1.5.2-2.2ubuntu1 (feisty, now)]
python2.5 [2.5.1~rc1-0ubuntu3 (feisty, now)]
python2.5-examples [2.5.1~rc1-0ubuntu3 (feisty, now)]
python2.5-minimal [2.5.1~rc1-0ubuntu3 (feisty, now)]
update-manager-core [1:0.59.20 (feisty, now)]
Laisser les dépendances suivantes non satisfaites :
gnome-applets recommande tomboy
Le score est de -3211

Accepter cette solution ? [Y/n/q/?]



ca fait peur hein :lol:
Modifié en dernier par oviri le 29 Avr 2007, 19:34, modifié 1 fois.
Avatar de l’utilisateur
oviri
Noobs
 
Message(s) : 357
Inscription : 20 Juin 2004, 01:17
Localisation : IRIPAU - UPORU

Message par dominix » 29 Avr 2007, 18:17

ca ressemble a des paquets non-edgy ajouter manuellement que le systeme d'upgrade n'est plus capable de mettre a jour.

tu devrait essayer d'enlever manuellement (dpkg -r ) un certain nombre de paquet bloquant genre f-spot et les lib mono, puis refaire le "aptitude -f install"

si aptitude crie trop, fait le avec apt-get puis met a jour par la suite, un par un le paquet restant non mis a jour.

NB : avant un dist-upgrade il faut toujours nettoyer tout les paquets dont aptitude mentionne qu'il n'ont pas été mis a jour.
Image
Avatar de l’utilisateur
dominix
Equipe LoLiTa
 
Message(s) : 581
Inscription : 17 Mars 2005, 16:53
Localisation : Moorea : Zone urbano-végétale

Message par oviri » 29 Avr 2007, 18:56

euh je voulais juste savoir si sur une feisty installé depuis un CD il y avais tout ces paquets cassés. Je peut en déduire que non d'apres ta réponsse dominix mais avant de faire du ménage je voulais m'assuré que je n'allais pas le faire pour rien.

dominix a écrit :NB : avant un dist-upgrade il faut toujours nettoyer tout les paquets dont aptitude mentionne qu'il n'ont pas été mis a jour.

je sors d'une dapper upgrader vers edgy (via aptitude pas via update-manager comme c'est le cas pour mon passage vers feisty donc aptitude -f install, je l'ai fait un paquet de fois avant de passer en feisty, et ma edgy étais, à prioris, parfaitement propre et à jour avant la migration.)

dominix a écrit :si aptitude crie trop, fait le avec apt-get puis met a jour par la suite, un par un le paquet restant non mis a jour.

aptitude s'en sortira tout seul, ça a été le cas lors du passage vers edgy, si toute fois les paquets ne sont pas cassées (ce qui m'étonne un peut quand même mais je voulais simplement m'en assurer pour ne pas avoir de problèmes).

je vais donc répéter ma question, est-ce que, quelqu'un ayant installer une feisty depuis le CD d'install, à le même résultat que moi en faisant un "sudo aptitude -f install"?

mauruuru roa.
Avatar de l’utilisateur
oviri
Noobs
 
Message(s) : 357
Inscription : 20 Juin 2004, 01:17
Localisation : IRIPAU - UPORU

Message par dominix » 29 Avr 2007, 19:00

oviri a écrit :...
est-ce que, quelqu'un ayant installer une feisty depuis le CD d'install, à le même résultat que moi en faisant un "sudo aptitude -f install"?


non (tm)
:)
Image
Avatar de l’utilisateur
dominix
Equipe LoLiTa
 
Message(s) : 581
Inscription : 17 Mars 2005, 16:53
Localisation : Moorea : Zone urbano-végétale

Message par oviri » 29 Avr 2007, 19:03

ua oti roa (c'est OK :) )
c'est parti pour un peut de ménage.
Avatar de l’utilisateur
oviri
Noobs
 
Message(s) : 357
Inscription : 20 Juin 2004, 01:17
Localisation : IRIPAU - UPORU

Message par oviri » 29 Avr 2007, 19:21

done
un coup d'aptitude -f install puis réinstallation des paquets que j'ai estimé essentiel (ubuntu-desktop network-manager network-manager-gnome desktop-effects) et hop tout niquel. Comme quoi, je penssais que passer par update-manager faisais ça tout bien mais non. Aussi, j'ai du confondre un peut la SID et ubuntu :D (mauvaise expérience de la unstable de chez Debian :'-( )
Avatar de l’utilisateur
oviri
Noobs
 
Message(s) : 357
Inscription : 20 Juin 2004, 01:17
Localisation : IRIPAU - UPORU

Message par dominix » 29 Avr 2007, 19:27

oviri a écrit :done
un coup d'aptitude -f install puis réinstallation des paquets que j'ai estimé essentiel (ubuntu-desktop network-manager network-manager-gnome desktop-effects) et hop tout niquel. Comme quoi, je penssais que passer par update-manager faisais ça tout bien mais non. Aussi, j'ai du confondre un peut la SID et ubuntu :D (mauvaise expérience de la unstable de chez Debian :'-( )


ca peux pas être pire que knoppix :)
Image
Avatar de l’utilisateur
dominix
Equipe LoLiTa
 
Message(s) : 581
Inscription : 17 Mars 2005, 16:53
Localisation : Moorea : Zone urbano-végétale

Message par oviri » 29 Avr 2007, 19:34

ah je ne sais pas, jamais essayé de knoppix (même en liveCD)
merci au fait dominix.
Avatar de l’utilisateur
oviri
Noobs
 
Message(s) : 357
Inscription : 20 Juin 2004, 01:17
Localisation : IRIPAU - UPORU


Retour vers Distributions

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité

cron